telechargement

Adaptabilité et liberté

Planning Biblio est un logiciel libre distribué sous  licence GPL v2, aussi appelée en français Licence Publique Générale GNU. Cette licence vous garantit les libertés suivantes

utilisation

La liberté d’installer et d’utiliser Planning Biblio pour quelque usage que ce soit 

adaptation

La liberté d’étudier le fonctionnement de Planning Biblio et de l’adapter à vos propres besoins en modifiant le code source, auquel vous avez un accès immédiat

distribution

La liberté de distribuer des copies à qui que ce soit, tant que vous n’altérez ni ne supprimez la licence

partage

La liberté d’améliorer Planning Biblio et de diffuser vos améliorations au public, de façon à ce que l’ensemble de la communauté puisse en tirer avantage, tant que vous n’altérez ni ne supprimez la licence

Prérequis

Pour installer Planning Biblio, vous devez avoir un serveur Apache ou NGINX, une base de données MySQL ou MariaDB,  PHP version 7.0 ou supérieure, les modules PHP suivant : json, mysqli, pdo, pdo_mysql, ldap (si vous souhaitez utiliser l’authentification ou l’importation LDAP), et curl (si vous souhaitez utiliser l’identification CAS).

INSTALLATION

Suivez le guide!

LES OUTILS GIT ET COMPOSER (RECOMMANDÉ)

COMPOSER

Composer est un logiciel gestionnaire de dépendances libre.

Téléchargez-le en suivant les indications fournies ici:

  https://getcomposer.org/download/


git

GIT est un outil de gestion d’évolution de contenus d’une arborescence.

Il s’installe avec le gestionnaire de paquet de votre distribution linux.

executer

Vous pouvez exécuter la commande composer update après avoir fait un alias du type:

composer=’php /chemin/vers/composer.phar’ ou directement taper la commande php -f /chemin/vers/composer.phar update


Utilisez ces outils et entrez le code de la manière suivante:

git clone https://github.com/planningbiblio/planningbiblio -b 19.10.xx planningbiblio

cd planningbiblio

composer update


 


Mise à jour

Attention!

Avant de mettre à jour Planning Biblio : sauvegardez votre base de données, le fichier include/config.php, votre éventuel fichier lang/custom.php et votre thème personnalisé si vous en avez un.

Important

Si vous souhaitez mettre à jour Planning Biblio depuis une version inférieure à 2.0, vous devez d’abord effectuer une mise à jour vers la version 2.0.3 en utilisant cette archive :  Planning Biblio 2.0.3Si vous utilisez un thème personnalisé et que vous effectuez une mise à jour depuis une version inférieure à 2.3.3, il devra être adapté ( voir le forum).Supprimez le dossier setup après l’installation et après les mises à jour



les outils git et composer:
si vous avez installé Planning Biblio avec git (recommandé)
Rendez-vous dans votre dossier Planning Biblio

Entrez le code de la manière suivante:

git reset –hard

git fetch origin 19.10.xx

git checkout -b 19.10.xx origin/19.10.xx

composer update

Conseil

Assurez-vous que les fichiers précités sont toujours en place après la mise à jour ou recopiez-le depuis votre sauvegarde.

Connectez-vous au planning : la mise à jour de la base de données démarre automatiquement.


Autres solutions

Autre solution d’installation:

Décompressez l’archive téléchargeable dans votre DocumentRoot


Autre solution de mise à jour:
Décompressez l’archive téléchargeable et copiez son contenu dans votre dossier planningbiblio


Dernière version (19.10.01)

Planning Biblio 19.10.01 ChangeLogRequis : PHP 7.0 ou supérieur

Guide d’installation  

Guide d’installation et de paramétrage

Manuel utilisateur

  Manuel Utilisateur